The Games

Here is our list of Apple Arcade games that are compatible with PS4 DualShock 4 / XBox One-S & MFi Controllers, newest releases are at the top.* Apple Arcade requires iOS13,iPadOS,tvOS13 or macOS Catalina.

(Click on images below to link for more info or download on Apple Arcade)  

Sunday, September 22nd 2019